chromeで画面がヘンになった。いろいろアップデートしたら!?

  • 2013.02.09 Saturday
  • 13:58
Chromeが変になったけど、いろいろやって直った顛末。

MacOSX 10.7.5とVMwareFusion 4.1.4のWindows7(64bit)のChromeで画面が変になった。
googleの検索ページ(あんなにシンプルなページ)ですら、びよ〜〜んと伸びたようになる。

きっかけは、WindowsアップデートとMcAfeeの更新とVMwareの更新をまとめてやったこと。
まとめてやりすぎて何が原因がわからない。
chromeを古いバージョンに戻したり、、、
chromeのDeveloperバージョンを入れてみたり、、、
Windowsで復元ポイントに戻したり、、、
Windowsで新しいユーザをつくってみたり、、、
、、、あきらめた。

そんなこんなで一ヶ月ほど経過した今しがた、googlingの結果にVMware Fusionのアップデートに問題ありとの情報が。VMware Fusionを5にすれば良いとか。でも5はスキップするって決めたので、どうしようかな。
ためしに、4.1.4のまま『3Dグラフィックの高速化』をオフにしてみたら直った。

JUGEMテーマ:コンピュータ


もうすぐマルチタッチトラックパッドのついた MacBook Pro

  • 2008.03.05 Wednesday
  • 00:45
もうすぐマルチタッチトラックパッドのついた MacBook Pro

マルチタッチトラックパッドに惹かれてMacBookPro

  • 2008.02.28 Thursday
  • 00:48
『マルチタッチトラックパッドに惹かれてMacBookPro』はこちらから。

Mac OS X に PHP をインストール

  • 2007.07.15 Sunday
  • 12:10
Mac OS X 10.4 にPHP をインストールしたときに遭遇したトラブルと対処方法

自前でセットアップした Apache(2.2系)・ MySQL(5.x系)と連携させる
PHP をインストールしようとしてハマった。
--------
./configure ....
make
........
/usr/bin/ld: Undefined symbols:
_res_nclose
_res_ninit
_res_nmkquery
_res_nsend
--------
なにやら resolv がらみにエラーのようである。

ググってみると、BIND がインストールされているとこうなるらしい。
ソリューションも書いてあるが解決しない。
仕方なくソースツリーをさまよって自力で解決策を見つける。
簡単にいうと、configure のあと、main/php.config.h を
書き換えてから make する、である。

--------
./configure ?
--with-apxs2=/usr/local/apache-2.2.4/bin/apxs ?
--with-openssl ?
--with-zlib ?
--with-bz2 ?
--enable-calendar ?
--with-gd=/usr/local ?
--with-jpeg-dir=/usr/local ?
--with-png-dir=/usr/local ?
--with-xpm-dir=/usr/X11R6 ?
--with-freetype-dir=/usr/X11R6 ?
--enable-gd-native-ttf ?
--enable-gd-jis-conv ?
--enable-mbstring ?
--with-mysql=/usr/local/mysql ?
--with-mysql-sock ?
--with-zlib-dir

main/php_config.h の HAVE_LIBBIND, HAVE_RES_SEARCHを "0" にする。
修正前;#define HAVE_LIBBIND 1
修正前;#define HAVE_RES_SEARCH 1
修正後:#define HAVE_LIBBIND 0
修正後:#define HAVE_RES_SEARCH 0

make
make test
make install
--------
"make test" でいくつか Fail がでているが、実害はなさそうなので
無視することにする。

ちなみに、各モジュールのバージョンは以下の通り。
apache-2.2.4
mysql-5.0.18
php-5.2.3
gd-2.0.35
jpeg-6b
lpng1218

QuickTime で H.264 ムービーが書き出せなくなった顛末

  • 2006.05.29 Monday
  • 23:04
Mac miniのMacOS10.3を10.4にアップデートしたら、QuickTimeProのQuickTimeムービー書き出しで、強制終了するようになってしてしまった。
QuickTimeのバージョンをみると、7.1.0。再生はちゃんとできる。しかし、ムービー情報をみると『現在のサイズ』が『BitPerSec』(?)になってたり、『再生FPS』の表示がおかしかったり。
なんかヘンなので、ぐぐる。
バージョンダウンや、レシートファイルの削除など、やることはいろいろありそうだ。が、QuickTimeインストールパッケージをダウンロードして上書き再インストールしてみることにした(ソフトウェア・アップデートでなく)。
結果、正常になりました。やっぱOSアップデートは問題ありですね。通常はクリーンインストールしかやらないんですけど、メンドウでアップデートしてしまった。急がば回れ。